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Rock Pool GIS Lab
Introduction
Geographers use maps and Geographic Information Systems (GIS) to examine the distribution of phenomena on earth’s surface. Biogeographers use GIS to examine the distribution of species on earth’s surface, track wildlife, examine habitat suitability and much more. This lesson introduces basic concepts of GIS including DATA LAYERS, SYMBOLOGY, FIELD CALCULATOR, SELECT BY ATTRIBUTES and MAP ELEMENTS. This lesson also introduces some of the tools you'll need to investigate questions of island biodiversity in Richmond’s Rock Pools such as the ArcToolbox NEAR tool.
Before you Begin
1. Browse to the location of the “RockPools” folder as shared by your instructor.
2. Make a copy of the entire “RockPools” folder, and paste it on your desktop. Close your Windows Explorer window – you will be working exclusively from your desktop copy, as the copy on the Equator file server cannot be edited.
ArcMap (GIS) Basics
3. Open “RockPoolsLab.mxd” from the COPY on your desktop. Make sure you save your work frequently, as ArcMap is prone to crashing (Ctrl + S is a quick shortcut)!
4. Once ArcMap opens, take a moment to familiarize yourself with the following elements of the program:
a. Map Display
b. Table of Contents
c. Tool Bars
d. ArcToolbox
[image: ]
5. The Table of Contents is where you get to see all of the different data layers that are part of the map. To toggle the layer on or off simply click on the checkmark [image: ] to the left of the layer name.
6. The Map Display is where you get to see all of your spatial data! It’s a little like what you see in google maps, except that you have to power to modify how each of the data layers look!
7. The Tool Bars at the top of ArcMap are where you can change your active tool. Here are a few things we will use:
a. Zoom In [image: ]: this lets you select an area to zoom in on in the map display.
b. Zoom Out [image: ]: this lets you zoom out of an area on the map display.
c. Pan [image: ]: this lets you move around the map display.
d. Select Elements [image: ]: this tool lets you interact with elements on the map.
8. ArcToolbox [image: ] is where you can access more advanced tools that we’ll use later!
Attribute Table Basics
9. First, let’s take a look at our data by checking out the Attribute Table!
a. In your Table of Contents, right click on the data layer named Rock Pools, and select “Open Attribute Table”
b. This will pull up a list of the rock pools and all of the information that has been gathered about each one.
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c. Note that if you click on the grey box at the left of a pool record in the Attribute Table the whole record will turn blue in the table and the corresponding pool will turn blue on the Map Display. When you right click this grey box, you can also select “Flash” or “Zoom To” to help you find the pool. 
[image: ]
d. If you’ve clicked “Zoom To” you can return to your previous extent (zoom level) by clicking the “Go back to previous extent” button [image: ] or by using the “Zoom out” tool [image: ].
Changing Symbology
10. There are lots of ways to visualize the data on the Map Display using the data we have about the pools. This is called modifying the data symbology.
11. Let’s start by changing the symbology of the Channel. 
a. This data layer represents the deepest portion of the river channel that runs through this area. Right click on the Channel data layer in the Table of Contents and select “Properties”. Go to the “Symbology” tab.
b. Clicking on the “Symbol” button will allow you to change the symbol color, size and type. Select a symbol you think is appropriate for a water feature.
[image: ]
12. Now let’s change the symbology of the Rock Pools themselves.
a. Right click on the Rock Pools data layer in the Table of Contents and select “Properties”. Go to the “Symbology” tab.
b. At the moment, the Rock Pools are being visualized with the “Single symbol” symbology type, meaning that they are all the same symbol. 
c. Let’s try visualizing the data by showing which pools are bigger or smaller. This will rely on the surface area field named “Surface Area” which is a number. 
d. Click to the “Quantities” section of the “Symbology” tab and select “Proportional symbols” – this will make each pool symbol bigger or smaller depending on the size of the pool.
e. Click the first drop down box called “Value” and select “Surface Area”.
f. You can change the color and shape of the pool points by clicking on the symbol below “Min Value” just as you did for the channel in step 11.
g. Click “OK” when you are done.
[image: ]

13. Save Map #1
a. Click File->Save a Copy and save this map as a jpeg with the title “LastName_FirstName_Map1”. This will save a picture of your map, which you will not be able to edit later, so make sure it looks nice! This is a great way to save maps that are complete and that need to be shared outside of ArcMap (in a lab write up, for example!)

14. We can also visualize the data using species richness or diversity. There are three fields in the data to choose from: 
a. [bookmark: _GoBack]“Richness Count” is a count of how many species were sampled for each pool (but not their abundance).
b. “Richness Chao” is an asymptotic estimate of the total number of species you’d find in the pool (if you continued to sample at the same rate).
c. “Diversity Simpsons” is an index of diversity which takes into account the relative abundance of each species. 
i. A Simpson's Index value ranges from 0 to 1 and is interpreted as the probability that two individuals drawn from the same community will belong to different species. By this logic, a community with a Simpson's Index value close to 0 would have very little diversity (dominated by a few species), while a value closer to 1 represents high diversity (relative abundance more even across species).
15. For this next section, pick one of these measures of species diversity or richness. We are going to change the symbology to visualize this attribute by a symbol color rather than by symbol size.
a. Right click on the Rock Pools data layer in the Table of Contents and select “Properties”. Go to the “Symbology” tab.
b. Select the “Quantities” section again, and this time pick “Graduated Colors”
c. From the drop down menu for the “Value” select one of the three measures in #14.
d. Change the “Color Ramp” drop down to a color scheme you like.
e. Change the symbol size of each color symbol to size 8 or higher by clicking on each symbol picture.
f. Click “OK”
[image: ]
[bookmark: _l5pl00egxg5e]Navigating the Layout View
16. Maps need several elements in order to be effective communication tools. Here are the basics:
a. Title: this tells the user what your map is about.
b. North Arrow: this tells the user where north is on your map.
c. Scale Bar: this lets the user see how big the things in your map are. 
d. Legend: this is a guide for the user to help them understand what the symbology means.
17. So far, we have been working in Data View in ArcMap. In order to create these elements, we will need to change over to ArcMap’s Layout View.
a. Data View [image: ]is used when working with data directly or for analysis. You can use your zoom, pan and select tools in this view. You cannot create the map elements described in #16 in this view.
b. Layout View [image: ]is used only when you are producing a map to publish or print. This view displays the last location you were zoomed to in Data View. You can’t use your zoom, pan or select tools, but you can flip back to Data View to change what area is displayed.
18. Toggle to Layout View:
a. At the bottom of the Map Display to the left of the scroll bar, there are four symbols. The first two let you toggle between Data View (left) and Layout View (right).
[image: ]
b. Click on the Layout View button.
c. Alternatively, you can use the “View” dropdown menu at the top of ArcMap (next to File and Edit) to toggle between views.
d. If your Layout View is not displaying all pools, toggle back to Data View and zoom in or out as needed then toggle back to Layout View.
19. Add a Title:
a. At the top of ArcMap click Insert->Title.
b. Name your map according to the richness or diversity measure you selected in #15. For example, “Rock Pools by Richness Count Score”.
c. You can move this map element around while you are in Layout View. 
d. You can change the size and other formatting elements of the title by double clicking on this map element.
20. Add a North Arrow:
a. At the top of ArcMap click Insert->North Arrow.
b. Select one of the North Arrow options and click “OK”.
c. You can change the location and size of the north arrow in Layout View.
d. The traditional location for the North Arrow is in the bottom right corner of the map.
e. You can add a background color by double clicking on the North Arrow and going to the “Frame” tab and selecting a color from the “Background” dropdown.
21. Add a Scale Bar:
a. At the top of ArcMap click Insert->Scale Bar.
b. Select one of the Scale Bar options and click “OK”.
c. You can change the location and size of the north arrow in Layout View.
d. The traditional location for the Scale Bar is in the bottom right corner of the map below or to the left of the North Arrow.
22. Add a Legend:
a. At the top of ArcMap click Insert->Legend.
b. Make sure you include “Rock Pools” and “Channel” in your “Legend Items” and then press “Next”.
c. Give your Legend a good title (or take it out if you think your map Title is strong!) - it should be descriptive, not just “Legend”. Click “Next”.
d. You can change the Legend appearance with this next window. It’s OK to accept the defaults too. Click “Next” for the next three panels.
e. Your Legend should appear on the Map Display! You can change the location and size of the Legend in Layout View.
f. The traditional location for the Legend is in the bottom left corner.
g. You can double click on the Legend to change the look and feel (HINT: The “Frame” tab lets you change the background color of the Legend).
h. You can change the name of the layers that display in the legend from the Table of Contents – simply click on the text and modify the name.
23. Export Map #2
a. Click File->Export Map and save this map as a jpeg with the title “LastName_FirstName_Map2”. This will save a picture of your map, which you will not be able to edit later, so make sure it looks nice! This is a great way to save maps that are complete and that need to be shared outside of ArcMap (in a lab write up, for example!)
Calculating New Attributes
24. Now that we’ve worked on ways to display data through symbology, let’s use some of ArcMap’s computing power to provide us new information.
25. In Island Biogeography, two of the major explanatory variables to consider when doing analysis are:
a. Size of a patch/island/pool
b. Distance from a source/mainland
In this analysis, you will explore two measures of pool isolation: distance from the channel (a source of aquatic species) and distance from nearest neighbor pool (relative isolation)
26. For this analysis, our source is the river channel. Pick a pool and measure the distance from the pool to the channel:
a. Make sure you are in Data View [image: ].
b. Select the Measure tool [image: ] from your Tool Bar.
c. Draw a line between any Rock Pool and the nearest part of the Channel line. 
d. Note the distance displayed in the Measure tool help box.
e. To stop measuring, click the Select Elements tool [image: ] on your Tool Bar.
27. Doing this for each pool individually would take a long time. Let’s calculate this distance for all pools using a specialized tool. First, we need to add a new field to the table that will contain the data for distance to source. 
a. Open the Attribute Table from the Table of Contents by right clicking the “Rock Pools” data layer and selecting “Open Attribute Table”.
b. Click the “Table Options” button [image: ] at the top left of the Attribute Table and select “Add Field”.
[image: ]
c. Give the new field the name: “DIST_CHANNEL”.
d. Give the new field the Alias: “Distance to Channel”.
e. This field will be a measurement, so our data type needs to be “Double”.
f. Click OK.
[image: ]
g. Scroll to the right in your Attribute Table to ensure that your new field appears.
28. Make sure that you do not have any Rock Pools selected. You can do this by clicking the dropdown menu: Selection->Clear Selected Features.
29. Next, we need to open the tool called Near. 
a. To do this, open ArcToolbox [image: ]by clicking on the dropdown menu: Geoprocessing->ArcToolbox. 
b. Double click on Near in the Proximity toolset in the Analysis Tools toolbox: 
[image: ]
c. “Input Features” should contain the “Rock Pools” data layer. Select it from the dropdown menu.
d.  “Near Features” should contain the “Channel” data layer. 
e. Leave all other options with the default and click “OK”.

30. The tool has added a new field to our data with the distance of each point to the channel! We need to move that information over into the field we created in step #27.
a. Open the Attribute Table and scroll to the right. You will see two new fields: “NEAR_FID” (the OBJECTID of the nearest feature) and “NEAR_DIST” (the distance to nearest feature). These are the automatic fields created whenever the Near tool is used. We don’t want to keep these fields because any time you run the Near tool again it will write over top of this information.
b. Right click on your “Distance to Channel” field at the top of the Attribute Table and select “Field Calculator”. Click “Yes” when prompted about calculating outside of an edit session.
c. The Field Calculator lets us write new values to our fields using other fields in the Attribute Table. 
d. In the pop up, scroll to the bottom of the list of Fields and double click on “NEAR_DIST” then click “OK”.
[image: ]
e. The pop up will close and your “Distance to Channel” field will now contain the data we generated!
31. Delete the “NEAR_FID” and “NEAR_DIST” fields by right clicking them in the Attribute Table and selecting “Delete Field”. Click “Yes” when prompted about deleting the field.
32. The second explanatory variable we will calculate is relative isolation. This measure is very similar to distance from channel, except this time we will be measuring the distance between pools instead of the distance to channel. Follow steps #27-31 except use the following:
a. When adding a new field use the details: Name = “DIST_POOL”, Alias = “Distance to Pool”, Type = Double.
b. When using the Near tool use the input variables: Input Features = “Rock Pools”, Near Features = “Rock Pools”.
c. When doing your Field Calculator use the equation: “Distance to Pool” = “NEAR_DIST”
d. Don’t forget to delete “NEAR_FID” and “NEAR_DIST” again when you’re done!
33. Export your Attribute Table:
a. To do this, select all features by opening the Attribute Table and clicking the “Table Options” menu  [image: ] and “Select All”.
b. Right click on the gray area to the left of the table, and click “Copy Selected”.
[image: ]
c. Open Microsoft Excel (or Google Sheets) and paste the copied features (ctrl+v).
d. [bookmark: _8bod8evsus2u]Save this file as “LastName_FirstName_AttributeTable.xlsx”. You will use this file to complete your additional biodiversity analyses (see attached assignment).
Species Distribution – Putting it all together
34. Let’s take a look at a few specific species with our data. There are 10 species fields provided in the dataset:
a. Leech
b. Physid Snail
c. Planorbid Snail
d. Pleurocerid Snail
e. Viviparid Snail
f. Asian Clam
g. Sideswimmer
h. Water Strider
i. Water Scavenger Beetle
j. Predaccous Diving Beetle
k. Damselfly
l. Skimmer Dragonfly
m. Mosquito
n. Bloodworm
35. Make a map using the knowledge you have gained and the instructions above that displays one of the following:
a. The presence/absence of your species of interest in each pool (HINT: Use “Categories” symbology – “Add Values” -> 0 will represent all pools with none of your species and “all other values” will represent all pools with one or more of your species).
b. The relative number of your species in the pools that contain it (HINT: Use “Quantities” symbology as in previous exercises).
36. Be sure your map has appropriate Title, that a reader can tell which species you have mapped (to edit the Title go to File -> Map Document Properties) and don’t forget to include the other map elements!
37. Export Map #3
a. Click File->Export Map and save this map as a jpeg with the title “LastName_FirstName_Map3”



Spatial Analysis (Available Extension for Analyzing Spatial Patterns)
38. Now let’s use a spatial tool to help us understand whether or not the species you are interested in are clustered. (nearest neighbor all pools, then species selections, compare nearest neighbor ratio)
a. This tool uses the active selection for its analysis, so let’s make sure we are working with all the Rock Pools to start. Go to “Symbology” menu by right clicking the layer in the table of contents. Select “Single Symbol” and then OK. All the Rock Pools should now be visible on the map display.
b. Open ArcToolbox [image: ] and navigate to Spatial Statistics Tools -> Analyzing Patterns -> Average Nearest Neighbor.
[image: ]
c. When using the Average Nearest Neighbor tool use the input variables: Input Features = “Rock Pools”, Distance = “Euclidean Distance”, Generate Report = Checked On, Area = Leave blank.
[image: ]
d. To access the results of this tool, click the “Geoprocessing” drop down menu on the top of your navigation bar and select “Results”.
e. Open the “Current Session” drop down, then the top entry, “Average Nearest Neighbor”. Double click on the item titled “Report File…”
[image: ]
39. This report will provide the results of the spatial analysis. For our purposes, we need to make note of several things:
[image: ]
a. The graph provided tells us if the data is clustered, random or dispersed (this is derived from p-value and z-score, as in other statistical analyses). 
b. The Rock Pools are clustered, which is important because it means if we are trying to look at a specific species within the pools, we need to know whether that species is as clustered as the pools overall or whether it is more or less clustered.
c. The Nearest Neighbor Ratio: The Nearest Neighbor Index is expressed as the ratio of the Observed Mean Distance to the Expected Mean Distance. The expected distance is the average distance between neighbors in a hypothetical random distribution. If the index is less than 1, the pattern exhibits clustering; if the index is greater than 1, the trend is toward dispersion or competition.[image: ]
d. Study Area is the total area used in calculating the Observed and Expected Mean Distances for the Rock Pools and therefore integral in the calculation of the Nearest Neighbor Ratio. We will use this number when we analyze a specific species within the pools as well.
40. Let’s look at a specific species within our pools now to determine whether it is more or less clustered than the pools overall. Select one of the species listed at the beginning of this section to focus on. 
a. Go to “Selection” drop down menu on the top of your navigation pane and select “Select by Attribute”.
b. When using the Select by Attributes tool use the input variables: Layer = “Rock Pools”, Method = “Create a new selection”. To create your query at the bottom, double click on the field name of the species you are interested in studying and then type “> 0”. The query should look something like this: 
[image: ]
c. Click “OK”. Now only the pools in which your species are found will be part of the analysis when we run the Average Nearest Neighbor Tool again.
41. Run the Average Nearest Neighboor Tool a second time:
a. Use the following input variables: Input Features = “Rock Pools”, Distance = “Euclidean Distance”, Generate Report = Checked On, Area = the Study Area from #39d.
b. To access the results of this tool, go back to the “Results” tab.
c. Under the “Current Session” there will now be two “Average Nearest Neighbor” dropdowns. The top entry will be the most recent analysis we ran. The second entry is the analysis we ran in #38. Double click on the item titled “Report File…” in the top “Average Nearest Neighbor” drop down.
42. Compare this Nearest Neighbor Ratio with the ratio from #38. Is the species you selected more or less clustered based on these two values? Why?
43. Save your two nearest neighbor reports as PDFs.  Depending on your operating system, you can do this by using File -> “Save as…” or File -> Print and “Print to PDF”. They should have the names: “LastName_FirstName_NearestNeighborAll” and “LastName_FirstName_NearestNeighborSpecies”
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