Using Linear Regression to Explore Environmental Factors Affecting
Vector-borne Diseases
STUDENT GUIDE FOR STATISTICS
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Excel Instructions
The first step is to open Microsoft Excel. Please do so.
Select a Blank Workbook. Save it now. Call it “Analysis of Disease XXXXX” or some other
appropriate file name.
We are going to use a small sample data for illustration. For a selection of vehicles, the weight of the
vehicle (in pounds) was measured and the efficiency of that same vehicle – measured in miles per
gallon (mpg) – was captured under a testing situation.
Now, we will put the data onto the spreadsheet. Look at the following table screenshot for the
suggested format.

Create column headings so you won’t get lost. The first column is your independent variable which, in
this case, is vehicle weight. In many texts, this variable is also called “explanatory.” The second
column is your dependent variable, the vehicle MPG. Likewise, other statistical references also refer
to this Y as the “response.” (Note that in Excel the first column is always the independent (X) and the
second column is always the dependent (Y). Please be careful.) Skip a line under the headings for
better organization. Create two more columns that will be filled in later. These are the predicted
values of the MPG that will be generated by the regression equation, and the residuals. These
residuals are the set of differences between “what you observe” and “what you would predict” using
the model you construct.
To perform some of the analysis, and to obtain some of the common statistics, you will need the
Analysis ToolPak. It is a collection of operations within EXCEL – you just don’t see it. It must be
called to the front to put in motion.
To load the Analysis ToolPak add-in, please execute the following steps :
➔ On the File tab, click Options.
➔ Under Add-Ins, select “Analysis ToolPak,” and click on the Go button.
➔ Check “Analysis ToolPak” and click on OK.
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➔ Within the “Add-In” window, click on OK.

The Analysis ToolPak is now ready to assist you in the analysis. We will come back to it after we get
a picture of the data. That picture will be a “scatterplot.” It is a good idea to get a visual display first
before getting into the weeds. The plot will provide insight into examining a relationship between two
variables. The plot may indicate that there is a reasonable or even strong linear – or straight line -relationship. That relationship may be direct or inverse. Or, on the downside, the plot may infer that
one variable has nothing to do with the other. That being the case, further numerical analysis may be
futile.
Here are the steps for getting a scatterplot:
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➔ Highlight the two columns of data.

➔ From the menu, click on Insert.
➔ Then click on Recommended Charts.
➔ The select Scatter (meaning scatterplot)
This plot is produced:

There seems to be a strong relationship between the miles per gallon achieved by a vehicle and its
weight. “Strong” means that, subjectively, you can see that as X increases, Y decreases in a fairly
straight-line fashion. The possible relationship portrayed in the plot is a motivation to go to the next
step. That step would be acquiring the correlation coefficient. The picture indicates that this statistic
should be a high negative number, perhaps fairly close to -1.00.
To go further, we will use the Analysis ToolPak.
On the “Data” tab, in the “Analysis” group, you can now click on Data Analysis. It is on the far right
of the screen.
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The following dialog box below appears. Click on Correlation.

Follow these steps :
➔ Click on OK.
➔ With the cursor in Input Range, highlight the numbers in both columns. Exclude the column
headings.
➔ For Output Range , choose a cell location far from the table to avoid overwriting the data. For
example, $G$1.

Note that the input range in the figure above does not represent the analysis we are now working on.
The important item is the figure itself, not the content within it.
The designated cell (G1) is the top left corner of the correlation table that is produced.
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The coefficient of weight and efficiency is -.85 , indicating a strong inverse relationship (as depicted
by the scatterplot).
With a scatterplot that portrays a strong linear relationship, and with a correlation coefficient value that
brings home the point that weight and efficiency are very much related, the next logical step is to
“quantify” that relationship with a model – specifically a linear regression model. This model will
provide the “best fit” of the data by minimizing the sum of the squared differences, each difference
resulting from subtracting the predicted value for MPG from the observed value for MPG for a given
value of vehicle weight. The theory behind this is contained in any number of statistics texts.
Here is the series of steps for regression :
➔
➔
➔
➔

Click on the Data tab.
Then Data Analysis.
Then Regression.
Then OK.

In the table, select the Select the Y– range by highlighting the column of Y-values which, in our case,
is MPG. In this example, the range for Y will be reflected as
$B$3:$B$12. Again,
just highlight the values only.
Then, in the table, select the X – range by highlighting the column of X-values which, in our case is
weight. In this example, the range for X will be reflected as $A$3:$A$12.
As was the case for correlation, the ranges given for both X and Y in the figure illustration do not
represent the current analysis of MPG and weight.
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➔ For the Output Range, select a location away from the data just as you did when finding the
correlation coefficient. For example, $I$1.
➔ Check on Residuals. You may also check on Residual Plots, Normal Probability Plots, and
other items that you may be interested in or which may contribute to your analysis.
➔ Click on OK only after you have made all your selections.
Here is the output produced for this example:
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There are many quantitative values to review, and each one has an interpretation. The most
important table (for our purposes) that Excel produces is the Model Coefficients Table, depicted in the
following screenshot.

Two important quantities are in this table. The slope of the best-fit line is calculated to be -.3333
(entitled “X-Variable” in the table). The y-intercept is 39.2333. The “best fit” line for the data then
becomes Y (MPG) = 39.23333 - .33333* X (Weight).
The Coefficient of Determination -- the R-Squared value -- is .7249. This is also – for a one-variable
linear relationship – the square of the correlation coefficient. This value implies that 72% of the
variability in the measured miles per gallon for the set if vehicles can be accounted for by the weights
of those vehicles. The remaining 28% of the variability in MPGs would be due to other variables
sources as types of terrain driven, highway versus urban driving, driver behavior, fuel types used, and
many other factors to include simple error.
To complete the table we started with, we can finish the other two columns – the predicted values and
the residuals. In Cell C3, enter “ = 39.2333-.33333*A3 “ and drag it down to the other cells in that
column. In Cell D3, enter “ = B3-C3,” and drag it down through the column.
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A discussion of the other values in the regression output, and the deliberation of aspects of a
particular disease to include other possible explanatory factors, are dependent upon sophistication of
the students, judgment of the faculty member, interest and motivation of the class, and time available.

MATHEMATICAL BACKGROUND
STATISTICAL TERMS RELATED TO ANALYSIS
The “Y” (Dependent Variable) This is the entity that you want to analyze and say something
about. Your goal is to discover other quantities – independent variables, sometimes called
explanatory variables – that may contribute to different values of Y. Your interest in Y – also termed a
response variable in many statistical references -- prompts you to gather one or more of these
possible “X s,” each of which may have a relationship with Y. The end result is a predictive model.
An example for an independent variable would be the miles per gallon (mpg) attained by a vehicle.
The “X” (Independent Variable) This is the entity you are going to explore to see if a strong
relationship exists with Y. If the relationship is evident, you may develop a predictive model to
estimate values for Y given specified values of X. An example of an independent variable is the
weight of a vehicle (in pounds or kilograms) that possibly affects the mpg achieved.
Scatterplot This is the plot of points ( X, Y ), gathered through a sample, that may portray the
existence of a relationship between the independent and dependent variables. However, in this
exercise, the only relationship that would be pursued is one for which the scatterplot forms a straight
line – a linear relation.
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Y0
This is an observed value of the dependent variable in a sample for an observed or controlled
value of the independent variable X.
“r” (Correlation Coefficient)
This is a measure of the strength and direction of the linear
relationship between the two quantitative variables X and Y. This coefficient ranges from -1 to +1.
Values close to -1 indicate a significant inverse relationship, meaning as X increases, Y will decrease.
Values close to 1 indicate both variables are increasing or both are decreasing. Values close to zero
signify little or no relation between the two entities.
“YP = b0 + b1 X” (Regression Line / Line of “Best Fit” ) This is the model that, for a linear
relationship between the two variables, estimates an average value of Y for an input value of X. An
example would be using the weight of a vehicle ( X ) to estimate the average miles per gallon ( Y )
achieved for a vehicle of that weight. “YP “ is called the predicted value of the response from the
model that has X as a predictor.
The quantity “ b0 “ is the Y-intercept of the straight line. In most algebra courses, and in some
statistics courses, the quantity is also designated as simply “b.” Similarly the slope in an algebra
course is usually represented by “ m. ” In statistics, owing to convention, this same quantity is usually
given the label “b1.”
Therefore “ Y = m X + b” and “YP = b0 + b1 X “ depict exactly the same relationship.
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Resource: Bodine, E. N., Lenhart, S., & Gross, L. J. (2014). Mathematics for the life sciences.
Princeton, NJ: Princeton University Press.
“e” (Residual) This is the difference between an observed value of Y obtained by the sample (Y0)
and the predicted value generated for a value of X (YP). Formula-wise, “e = Y 0 – Y P .” The sum of
all the residuals is zero. The smaller in magnitude the set of residuals is, the better the linear model
fits the data.
“R2 ” (Coefficient of Determination) This percentage represents the amount of variability in the
response ( Y ) (dependent) accounted for by the presence of a predictor ( X ) (independent). The
remaining percent – “ 100% - R2 “ – may be accounted for by one or more other explanatory variables
or simply error. For a linear model, “ R 2 = r2 .”
Note a low coefficient of determination means a weak correlation between the two features being
considered. In some ecological data, weak correlations can often occur, but even a weak correlation
can be important. Sometimes a feature with a weak correlation can be combined in a regression with
another feature and corresponding observed output to obtain a stronger correlation.
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